
Using the Acrobat XI Pro Accessibility Checker
Determine how easily persons with disabilities can access PDF 
documents with the Adobe Acrobat XI Pro Accessibility Checker
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The accessibility checking tools in Adobe Acrobat XI Pro—Accessibility Checker (Full Check) and 
the Make Accessible action wizard—can identify many issues in PDF documents that may be in 
conflict with Adobe’s interpretations of the accessibility guidelines referenced in the application 
and its documentation. These tools do not check documents for all accessibility criteria, 
including those in such referenced guidelines, and Adobe does not warrant that documents 
comply with any specific guidelines or regulations.

The Make Accessible Action Wizard
The Make Accessible action wizard walks users through the steps required to make a PDF 
accessible. It prompts to address accessibility issues, such as a missing document description 
such a document title. It looks for common elements that need further action, such as scanned 
text, form fields, tables, and images without alternative text. This action wizard can be run 
on all PDFs except dynamic forms (XFA documents) and portfolios. The last step of the Make 
Accessible action wizard is to run the Acrobat Pro Accessibility Checker (Full Check). For 
complete instructions on how to make documents accessible and repair the accessibility tag 
structure of a document refer to the document titled “Adobe Acrobat XI Pro Accessibility Repair 
Workflow”.

Accessibility Checker (Full Check)
Use the Accessibility Full Check to perform a thorough check for many characteristics of 
accessible PDFs, such as the use of alternative text on images, the presence of tags, document 
language, and fonts that can be mapped reliably to Unicode text.

From the Accessibility Checker dialog, it is possible to choose which kinds of accessibility issues 
to look for. There are also options to view and save the results. To run the Accessibility Full 
Check, perform the following:

1.	 Open the Accessibility Tool pane.

2.	 Select View > Tools > Accessibility from the Adobe Acrobat XI Pro menu. 
(Refer to “Figure 1. Acrobat XI Pro Accessibility Full Check Tool” on 
page 2.)

3.	 Select Full Check from the Accessibility tools.

4.	 The Accessibility Checker Options dialog appears (Refer to “Figure 2. 
Acrobat XI Pro Accessibility Checker Options Dialog” on page 2).

5.	 Set Report Options.

6.	 You can save the results as an HTML file or attach the report to the 
document.

7.	 Select a page range if you prefer to perform a check on individual sections 
of a document.

8.	 Select checking options.
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9.	 Choose a category from the dropdown, and then select the accessibility 
options to check for. By default, everything but “tables must have a 
summary” is checked.

10.	You can select Document; Page Content; Forms, Tables and Lists; and 
Alternate Text and Headings to reveal checkboxes that let you set the 
level of testing that you want Acrobat to perform.

11.	Activate the Start Checking button.

Figure 1.   Acrobat XI Pro Accessibility Full Check Tool

Figure 2.   Acrobat XI Pro Accessibility Checker Options Dialog

Figure 3.  After the check is complete, the results are displayed via the Accessibility Checker 
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panel. (See “Figure 4. Acrobat Xi Pro Accessibility Checker Panel” on page 3.)

Figure 4.  Acrobat Xi Pro Accessibility Checker Panel

If a report was checked to be created in the Accessibility Checker Options dialog, the results are 
available in the selected folder or an attachment. (See “Figure 5. Acrobat XI Pro Accessibility 
Report” on page 4.) The Accessibility Report can also be displayed by activating the 
Accessibility Report tool command in the Accessibility tools pane.
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Figure 5.   Acrobat XI Pro Accessibility Report

The Accessibility Full Check feature is unable to distinguish the intention of the document 
author such as whether a figure is purely decorative, so some issues it reports may not affect 
the functional accessibility of the document. Manual review of the issues may be required to 
determine whether to fix or ignore the issue.

Accessibility Checker Options
The Accessibility Checker (Full Check) has the following options that can be selected:

•	 Document

•	 	Accessibility permission flag is set

•	 	Document is not image-only PDF

•	 	Document is tagged PDF

•	 	Document structure provides a logical reading order

•	 	Text language is specified

•	 	Document title is showing in title bar

•	 	Bookmarks are present in large documents

•	 	Document has appropriate color contrast

•	 Page Content

•	 	All page content is tagged

•	 	All annotations are tagged

•	 	Tab order is consistent with structure order

•	 	Reliable character encoding is provided

•	 	All multimedia objects are tagged

•	 	Page will not cause screen to flicker

•	 	No inaccessible scripts

•	 	Navigation links are not repetitive

•	 	Page does not require timed responses
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•	 Forms, Tables and Lists

•	 	All form fields are tagged

•	 	All form fields have description

•	 	TR must be a child of Table, THead, TBody, or TFoot

•	 	TH and TD must be children of TR

•	 	Tables must have headers

•	 	Tables must contain the same number of columns in each row and 
rows in each column

•	 	Tables must have a summary

•	 	LI must be a child of L

•	 	Lbl and LBody must be children of LI

•	 Alternate Text and Headings

•	 	Figures require alternate text

•	 	Alternate text that will never be read

•	 	Alternate text must be associated with some content

•	 	Alternate text should not hide annotation

•	 	Elements require alternate text

•	 	Appropriate heading nesting

Accessibility Checker Panel

Once a report has been run, the issues that have been found are displayed in the Accessibility 
Checker panel. The results tree displays one of the following states for each rule check (See 
“Figure 6. Acrobat Rule Check States” on page 6):

•	 Passed: The item passed this accessible check.

•	 Passed Manually: The item was marked passed by manual inspect.

•	 Skipped By User: The rule was not selected in the Accessibility Checker 
Options dialog box.

•	 Needs Manual Check: The Full Check feature could not check the item 
automatically. Verify the item manually.

•	 Failed: The item did not pass the accessibility check.
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Figure 6.  Acrobat Rule Check States

To fix a failed check after running Accessibility Full Check, activate the context menu—right-click 
(Windows) or Control-click (Mac OS) the item in the Accessibility Checker panel. Choose one 
of the following options from the context menu (See “Figure 7. Accessibility Checker Panel 
Showing Issue States for each Checker Option” on page 7):

•	 Fix: Acrobat either fixes the item automatically, or displays a dialog box 
prompting the user to fix the item by entering information or making 
a choice. For example, a dialog is displayed allowing the user to enter 
alternative text for an image.

•	 Skip Rule: Deselects this option in the Accessibility Checker Options 
dialog box for future checks of this document, and changes the item 
status to Skipped.

•	 Explain: Opens the online Help.

•	 Check Again: Runs the checker again on all items. Choose this option 
after modifying one or more items.

•	 Show Report: Displays the accessibility report for the page range/
document with links to tips on how to repair failed checks. The link to tips 
is the same as the help that is provided by the “explain” item. Once the 
report is shown, a new option to attach the report also appears.

•	 Options: Opens the Accessibility Checker Options dialog box where 
checking options can be set.
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Figure 7.  Accessibility Checker Panel Showing Issue States for each Checker Option

Accessibility Checker Option Details
This section provides information on each option in the Accessibility Checker. Please refer to the 
“Adobe Acrobat XI Pro Accessibility Repair Workflow” document for details on how to address 
issues for each category.

Documentation Category

Accessibility permission flag: A document author can specify that no part of an accessible PDF 
is to be copied, printed, extracted, commented on, or edited. This setting can interfere with the 
user of a screen reader’s ability to read the documents screen readers must be able to copy or 
extract the document’s text to convert it to speech.

This flag reports whether it’s necessary to turn on the security settings that allow accessibility.

To fix the rule automatically, select Accessibility Permission Flag on the Accessibility Checker 
panel. Then, choose Fix from the Options menu.

Note: 	 Refer to the related WCAG section: 1.1.1 Non-text Content. (A), 4.1.2 Name, role, 
value

Image-only PDF: Reports whether the document contains non-text content that is not 
accessible. If the document appears to contain text, but doesn’t contain fonts, it could be an 
image-only PDF file.

To fix this item automatically, select Image-only PDF on the Accessibility Checker panel, and 
choose Fix from the Options menu. This will open the “Recognize Text - General Settings” dialog 
and then perform optical character recognition (OCR) on the document.

Note: 	 See the related WCAG section: 1.1.1. Non-text content (A)
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Tagged PDF: If this rule check fails, the document is not tagged to specify the correct reading 
order for reflow and assistive technology. Documents without tags also do not provide 
information describing the logical structure and relationship of elements to users of assistive 
technology.

To fix this item automatically, select Tagged PDF on the Accessibility Checker panel, and then 
choose Fix from the Options menu. Acrobat automatically adds tags to the PDF. The tags that 
were added still must be reviewed to ensure they are correct.

Note: 	 Refer to the related WCAG section: 1.3.1 Info and Relationships, 1.3.2 Meaningful 
Sequence, 2.4.1 Bypass Blocks, 2.4.4 Link Purpose, 2.4.5 Multiple Ways, 2.4.6 
Headings and labels, 3.1.2 Language of Parts, 4.1.2 Name, role, value

Logical reading order: Verify this rule check manually. Make sure that the reading order 
displayed in the Tags panel reflects the logical reading order of the document.

Primary language: Setting the document language in a PDF enables some screen readers to 
switch to the appropriate language. This check determines whether the primary text language 
for the PDF is specified. If the check fails, set the language.

To set the language automatically, select Primary Language in the Accessibility Checker tab, and 
then choose Fix from the Options menu. Choose a language in the Set Reading Language dialog 
box, and then click OK. This does not set the language for specific parts of the document that 
may be in different languages. To set specific portions of the document in different languages 
refer to the Adobe Acrobat XI Pro Accessibility Repair Workflow guide.

Note: 	 See the related WCAG section: Language of Page (Level A)

Title: Reports whether there is a document title. Document authors can choose to have the title 
appear in the Acrobat or Adobe Reader application title bar rather than the document file name.

To fix the title automatically, select Title in the Accessibility Checker tab, and choose Properties 
from the Options menu. Enter the document title in the Description dialog box (deselect Leave 
As Is, if necessary).

Note: 	 See the related WCAG section: 2.4 Page Titled (Level A)

Bookmarks: This check fails when the document has 21 or more pages, but does not have 
bookmarks that parallel the document structure.

To add bookmarks to the document, select Bookmarks on the Accessibility Checker panel, and 
choose Fix from the Options menu. In the Structure Elements dialog box, select the element(s) 
that you want to use as bookmarks, and click OK (See “Figure 8. Fix missing bookmarks in 
Acrobat” on page 9). You can also access the Structure Elements dialog box by clicking the 
Options menu on the Bookmark tab.

Note: 	 See the related WCAG sections: 2.4.1 Bypass Blocks (Level A), 2.4.5 Multiple 
Ways (Level AA)
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Figure 8.  Fix missing bookmarks in Acrobat

Color contrast: When this check fails, it’s possible that the document contains content that is 
not accessible to people who have low vision or color deficiencies.

To fix this issue, make sure that the document’s content adheres to the guidelines outlined in 
WCAG section 1.4.3 or include a recommendation that the PDF viewer use high-contrast colors 
and verify that all content is readable in the high-contrast color scheme:

To check the document in a high contrast color scheme perform the following:

1.	 Choose Edit > Preferences (Windows) or Acrobat > Preferences (Mac OS).

2.	 Choose the Accessibility category.

3.	 Select Replace Document Colors, and then select Use High-Contrast 
Colors. Choose the color combination that you want from the pop-
up menu, and then click OK (See “Figure 9. Adjust viewer to display 
document with high contrast settings” on page 10).
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Figure 9.  Adjust viewer to display document with high contrast settings

Page content

Tagged content: This check reports whether all content in the document is tagged. Make sure 
that all content in the document is either included in the Tags tree, or if decorative marked as an 
artifact.

Perform one of the following to fix this check:

•	 If the content is purely decorative, set it as an artifact.

•	 Use the Touch Up Reading Order tool to tag the content.

•	 Use the Tag panel to tag the content.

Please refer to the Adobe Acrobat XI Pro Accessibility Repair Workflow Guide for instructions on 
how to tag content.

Note: 	 See the related WCAG sections: 1.1.1 Non-text content (A), 1.3.1 Info and 
Relationships (Level A), 1.3.2 Meaningful Sequence (Level A), 4.1.2 Name, role, 
value

Tagged annotations: This option checks whether all annotations are tagged. Make sure that 
annotations such as comments and editorial marks (such as insert and highlight) are either 
included in the Tags tree if meaningful, or marked as artifacts if they’re purely decorative or 
duplicated in the content.

•	 If the content is purely decorative, set it as an artifact.

•	 Use the Tag Panel and the Find command to search for and tag the 
content as an annotation.

Please refer to the Adobe Acrobat XI Pro Accessibility Repair Workflow Guide for instructions on 
how to tag annotations.

To have Acrobat assign tags automatically to annotations as they’re created, choose Tag 
Annotations from the Options menu on the Tags panel. This is the easiest approach to tag 
annotations that have not already been created, as the annotation tags will appear in the correct 
location in the reading order of a properly tagged document.
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Note: 	 See the related WCAG section: 1.3.1 Info and Relationships (Level A), 4.1.2 Name, 
role, value

Tab order: Because the Tab key is often used to navigate links, annotations, and form fields in a 
PDF, it’s necessary that the tab order parallels the document structure.

To fix the tab order automatically, select Tab Order on the Accessibility Checker panel, and 
choose Fix from the Options menu. This will specify the tab order to follow the document 
structure.

Note: 	 See the related WCAG section: 2.4.3, Focus Order (Level A)

Character encoding: Specifying the encoding helps PDF viewers present users with readable 
text. However, some character-encoding issues are not repairable within Acrobat.

To ensure proper encoding, do the following:

•	 Verify that the necessary fonts are installed on your system.

•	 Use a different font (preferably OpenType) in the original document, and 
then re-create the PDF.

•	 Re-create the PDF file with a newer version of Acrobat Distiller.

•	 Use the latest Adobe PostScript driver to create the PostScript file, and 
then re-create the PDF.

Note: 	 The WCAG does not directly address Unicode character mapping.

Tagged multimedia: This rule checks whether all multimedia objects are tagged. Make sure that 
content is either included in the Tags tree or, if decorative or duplicative, marked as an artifact.

Perform one of the following to fix this check:

•	 If the content is purely decorative, set it as an artifact.

•	 Use the Touch Up Reading Order tool to tag the content.

•	 Use the Tag panel to tag the content.

Please refer to the Adobe Acrobat XI Pro Accessibility Repair Workflow Guide for instructions on 
how to tag content.

In addition to providing tags and description of all multimedia, captions (for people who are 
deaf or hard of hearing) or audio descriptions (for people who are blind or visually impaired)
may need to be synchronized with the multimedia. Please refer to the relevant guideline or 
standard for multimedia requirements.

Note: 	 See the related WCAG sections: 1.1.1 Non-text Content. (A), 1.2.1 Audio- only 
and Video- only (Prerecorded). (A), 1.2.2 Captions (Prerecorded). (A), 1.2.3 Audio 
Description or Media Alternative (Prerecorded). (A), 1.2.5 Audio Description 
(Prerecorded). (AA)
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Screen flicker: Elements that make the screen flicker, such as animations and scripts can cause 
seizures in individuals who have photosensitive epilepsy. These elements can also cause 
difficulty for users with low vision and people with cognitive disabilities.

If the Screen Flicker rule fails, manually remove or modify the script or content that causes 
screen flicker.

Note: 	 See these related WCAG sections: 2.3.1 Three Flashes or Below Threshold. (Level 
A)

Scripts: Content cannot be script-dependent unless both content and functionality are 
accessible with the keyboard and to assistive technologies. Make sure that scripting does not 
interfere with keyboard navigation or prevent the use of any input device.

Check the scripts manually. Remove or modify any script or content that compromises 
accessibility.

Note: 	 See these related WCAG sections: 1.1.1 Non-text Content. (A), 2.1.1 Keyboard 
(Level A), 2.2.2 Pause, Stop, Hide. (Level A), 4.1.2 Name, role, value

Timed responses: This check applies to documents that contain forms with JavaScript. If the rule 
check fails, make sure that the page does not require timed responses. Edit or remove scripts 
that impose timely user responses so that users have enough time to read and use the content.

Note: 	 See the related WCAG section: 2.2.1 Timing Adjustable. (Level A)

Navigation links: For URLs to be accessible to screen readers, they must be active links that 
are correctly tagged in the PDF document and keyboard accessible. (The best way to create 
accessible links is with the Create Link command, which adds link objects that screen readers 
require to recognize a link.) Use the Tags panel’s Find command to properly tag Links that are 
not accessible.

Link text must also be understandable on its own without surrounding content. If this rule check 
fails, check navigation links manually and verify that the content does not have links with an 
identical name but different target locations. Either change the link text or add actual text to the 
link tag to provide additional description out of context for users of screen readers.

Documents must also provide a way for users to skip over items that appear multiple times. 
For example, if the same links appear on each page of the document, also include a bookmark 
element to skip past the repetitive link group to the next tagged element in the structure . Links 
can not be used to skip past repetitive links as links can not focus tags in the tree and only scroll 
or zoom to a particular page view.

Note: 	 See the related WCAG section: 2.4.1 Bypass Blocks (Level A), 2.1.1 Keyboard 
(Level A), 2.4.4 Link Purpose (In Context) (Level A).

Forms

Tagged form fields: All form fields must be tagged with a form tag and form object element and 
part of the document structure. In addition, field descriptions (labels) must be provided via the 
tooltip form field property to provide the user with a label or instructions for a field.
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To tag form fields, choose Tools > Accessibility > Add Tags To Form Fields. This add the tags and 
form object elements to the form fields in the proper location in the Tags panel. This step does 
not add field descriptions.

Note: 	 See the related WCAG sections: 1.3.1 Info and Relationships. (Level A), 4.1.2 
Name, role, value

Field descriptions: All form fields must have a text label/description (this is set via the form 
field’s tooltip property).

To add a text description to a form field, use the form tools. Please refer to the “Adobe Acrobat 
XI Pro Accessibility Form Guide” document for complete instructions on how to set form field 
descriptions. Accessibility guidelines and standards may also require that visual labels be 
present. The tooltip property is only visible via the mouse and not the keyboard, thus, on-
screen labels should also be provided for all user input.

Note: 	 See the related WCAG sections: 1.3.1 Info and Relationships. (Level A), 3.3.2 
Labels or Instructions (Level A), 4.1.2 Name, role, value

Alternate Text

Figures alternate text: Make sure that images in the document either have alternate text or, if 
decorative, are marked as artifacts.

If this check fails, perform one of the following:

•	 Select Figures Alternate Text in the Accessibility Checker panel, and 
choose Fix from the Options menu (or context menu). Add alternate text 
as prompted in the Set Alternate Text dialog box (See “Figure 10. Set 
Alternate Text through the Fix option in the Accessibility Checker” on 
page 14).

•	 Use the Tags panel to add alternate text for images in the PDF.

•	 Use the Tags panel, Content Panel, or Touch Up Reading Order tool to 
make the content an artifact.

Note: 	 See the related WCAG section: 1.1.1 Non-text Content. (A)
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Figure 10.  Set Alternate Text through the Fix option in the Accessibility Checker

Nested alternate text/actual text:

Screen readers do not read the alternate/actual text for nested elements. Therefore, do not 
apply alternate text to elements with children unless the alternative text or actual text covers the 
content for these elements as well. Alternative text is used to provide an alternative for images 
(figures). Actual text is used to provide an alternative to text content.

Remove alternate/actual text from nested elements via the Tags panel. For more information 
on using alternative text and actual text refer to the Adobe Acrobat XI Pro Accessibility Repair 
Workflow Guide.

Refer to the related WCAG success criteria: 1.1.1 Non-text Content (Level A).

Associated with content: Make sure that alternate text is always an alternate representation for 
content on the page. If an element has alternate text, but does not contain any page content, 
there is no way to determine which page it is on. If the Screen Reader Option in the Reading 
preferences is not set to read the entire document, then screen readers never read the alternate 
text.

To fix this issue, assign page content to the tag that contains the alternative/actual text.

Note: 	 See the related WCAG section: 1.1.1 Non-text Content. (A)

Hides annotation: Alternate text can not hide an annotation. If an annotation is nested under a 
parent element with alternate/actual text, then a screen reader will not announce it.

Remove alternate/actual text from parent element. If alternate/actual text is needed make 
sibling objects out of content and the annotation and assign the actual/alternate text to the 
sibling tag. For more information on using alternate text and actual text, refer to the Adobe 
Acrobat XI Pro Accessibility Repair Workflow Guide.

See the related WCAG sections: 1.3.1 Info and Relationships. (Level A), 4.1.2 Name, role, value

Other elements alternate text: This option checks for content other than figures that requires 
alternate text such as multimedia, annotation, or 3D models. Make sure that alternate text is 
always an alternate representation for content on the page. If an element has alternate text 
but does not contain any page content, there is no way to determine which page it is on. If the 
Screen Reader Options in the Reading preferences is not set to read the entire document, then 
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screen readers won’t read the alternate text. If additional description is required for the object 
beyond what can be provided in alternative text, provide a on-page description or link to a 
description of the non-text object.

Note: 	 See the related WCAG section: 1.1.1 Non-text Content. (A)

Tables

Because table structure can be complex, it is best practice to check them for accessibility 
manually.

Rows: This check indicates whether each TR in a table is a child of Table, THead, TBody, or 
TFoot.

To fix this issue ensure that any TR tags are a child of a Table, THead, TBody, or TFoot tag.

Note: 	 Related WCAG section: 1.3.1 Info and Relationships. (Level A)

TH and TD: This check indicates whether a proper table structure exists. TH and TD must be 
children of a TR element; if not this check fails.

To fix this issue, ensure that TH or TD tags are place under a TR tag.

Note: 	 See related WCAG section: 1.3.1 Info and Relationships (Level A)

Headers: For accessibility, it’s necessary that all tables in the PDF have a header.

To fix this issue, ensure that all tables contain table header cells.

Note: 	 See the related WCAG section: 1.3.1 Info and Relationships (Level A)

Regularity: To be accessible, tables must contain the same number of columns in each row, and 
rows in each column.

To fix this issue, ensure that each table row has the same number of columns or the ColSpan and 
RowSpan properties of a cell are set properly to account for all cells in a row.

Note: 	 See the related WCAG section: 1.3.1 Info and Relationships (Level A)

Summary: Table summaries are optional unless the table data cannot be understood without it. 
Summaries can improve accessibility in complex data tables or when the way in which the data 
is read may be important.

To fix this issue, provide a table summary for data tables where it is needed to make the data 
easier to understand, or to provide instructions on the data should be reviewed.

Note: 	 See the related WCAG section: 1.3.1 Info and Relationships. (Level A)
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Lists

List items: This check reports whether each LI is a child of L tag. When this check fails, the 
structure of this list is incorrect. Lists must have the following structure: a List element must 
contain List Item elements; List Item elements can only contain Label elements and List Item 
Body elements.

To fix this issue, ensure that all list item elements have a parent L tag.

Note: 	 See the related WCAG section: 1.3.1 Info and Relationships. (Level A)

Lbl and LBody: Lists must have the following structure: a List element must contain List Item 
elements; List Item elements can only contain Label elements and List Item Body elements. 
When this check fails, the structure of this list is incorrect.

To fix the list structure, use the Tags panel to place Lbl and LBody elements under each list item. 
The list bullet or number should be a text node of the Lbl tag and the list item text a text node 
of the LBody tag.

Note: 	 Refer to the related WCAG success criteria: 1.3.1 Info and Relationships (Level 
A)

Headings

Appropriate nesting: This rule checks nested headings. When this check fails, headings are 
not nested properly. For example, a level 1 heading should precede a level 2 heading, etc. The 
Accessibility Checker is not able to determine when heading structures must be used—that 
must be determined by manually reviewing the document.

To fix this issue, ensure that all heading levels are nested accordingly with no missing heading 
levels. Use the Tags Panel or Touch Up Reading Order tool to assign heading tags.

Refer the related WCAG section: 1.3.1 Information and Relationships. (Level A). The order of 
headings is not required under WCAG, and is only an advisory technique.

Continue Checking Until All Issues are Addressed

Repeat the process of running the Accessibility Checker and associated repair techniques along 
with the Hints for Repair until the Accessibility Checker indicates “Passed” for all selected tests 
(See “Figure 11. A Successful Accessibility Check” on page 17).

Note: 	 While the Accessibility Checker helps evaluate the accessibility of a document 
and helps identify areas that may be in conflict with Adobe’s interpretations 
of the referenced guidelines, the Accessibility Checker can not automatically 
check all accessibility guidelines and criteria, including those in such referenced 
guidelines, and Adobe does not warrant that any documents will comply with 
any specific guidelines or regulations. Please consult with appropriate legal 
counsel for guidance on compliance with the referenced guidelines or any other 
accessibility guidelines.
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Figure 11.  A Successful Accessibility Check

Additional Functional Validation Techniques
The Accessibility Checker can evaluate many of the technical requirements for accessibility. The 
best way to test the functional accessibility of a document is to use the document with the same 
tools that readers will use. It is recommended to review the document with assistive technology 
including a screen reader. Even when a screen reader is not available, the following methods 
provided by Acrobat should be used to check the accessibility of a PDF file:

Use Reflow view to quickly check reading order:

1.	 Activate the View > Zoom > Zoom Text.

2.	 Enter 200 in the zoom field.

3.	 Activate the View > Zoom.

4.	 Activate The reflow option.

5.	 Verify that all content appears in the correct order.

6.	 Verify that all content is readable while zoomed.

Use Read Out Loud to experience the document as it will be heard by readers who use this 
text-to-speech tool.

1.	 Activate > View > Read Out Loud > Activate Read Out Loud

2.	 Activate > View > Read Out Loud > Read this page only

3.	 Verify that all page content is announced in the correct order.
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4.	 Repeat for each page.

Save the document as accessible text and then read the saved text file in a word-processing 
application to experience the document as it will be read by readers who may emboss the 
document in Braille.

1.	 Activate File > Save as > Text Plain (.txt)

2.	 Select the desired location.

3.	 Activate the Save button.

WCAG 2.0 Mapping to PDF/UA
The table below provides a mapping between WCAG 2.0 success criteria, the PDF/UA standard 
(ISO 14289-1) and PDF techniques for WCAG 2.0.

WCAG 2.0  	 ISO 14289 -1 (File)  	 Techniques
1.1.1 Non-text Content. (A) •	 7.3 addresses content 

requiring text alteration.

•	 7.18.1 paragraph 4 
addresses control 
descriptions.

•	 7.18.6.2 addresses time-
based media alternatives. 
Test, Sensory, and 
CAPTCHA use cases are 
addressed via the technical 
means used.

•	 7.1 paragraph 1, sentence 2 
addresses decoration.

•	 PDF1

•	 PDF4

1.2.1 Audio- only and Video- 
only (Prerecorded). (A)

•	 7.18.6.2 addresses time-
based media alternatives. 
Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
media-equiv-av-only-alt

1.2.2 Captions (Prerecorded). 
(A)

•	 7.18.6.2 addresses time-
based media alternatives. 
Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
media-equiv-captions

http://www.w3.org/TR/WCAG20-TECHS/PDF1.html
http://www.w3.org/TR/WCAG20-TECHS/PDF4.html
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-av-only-alt
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-av-only-alt
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-av-only-alt
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-captions
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-captions
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-captions
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WCAG 2.0  	 ISO 14289 -1 (File)  	 Techniques
1.2.3 Audio Description 
or Media Alternative 
(Prerecorded). (A)

•	 7.18.6.2 addresses time-
based media alternatives. 
Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
media-equiv-audio-desc

1.2.4 Captions (Live). (AA) •	 Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
media-equiv-real-time-
captions

1.2.5 Audio Description 
(Prerecorded). (AA)

•	 7.18.6.2 addresses time-
based media alternatives. 
Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
media-equiv-audio-desc-
only

1.2.6 Sign Language 
(Prerecorded). (AAA)

•	 Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

1.2.7 Extended Audio 
Description (Prerecorded). 
(AAA)

•	 Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance

1.2.8 Media Alternative 
(Prerecorded). (AAA)

•	 7.18.6.2 addresses time-
based media alternatives. 
Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

1.2.9 Audio- only (Live). 
(AAA)

•	 Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

1.3.1 Info and Relationships. (Level 
A)

•	 7.1 - 7.10 and 7.20 address 
structure and relationships 
in content.

•	 7.17 and 7.18 address 
structure and relationships 
in annotations.

•	 PDF6

•	 PDF9

•	 PDF10

•	 PDF11

•	 PDF12

•	 PDF17

•	 PDF20

•	 PDF21

http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-audio-desc
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-audio-desc
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-audio-desc
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-real-time-captions
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-real-time-captions
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-real-time-captions
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-real-time-captions
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-audio-desc-only
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-audio-desc-only
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-audio-desc-only
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-audio-desc-only
http://www.w3.org/TR/WCAG20-TECHS/PDF6.html
http://www.w3.org/TR/WCAG20-TECHS/PDF9.html
http://www.w3.org/TR/WCAG20-TECHS/PDF10.html
http://www.w3.org/TR/WCAG20-TECHS/PDF11.html
http://www.w3.org/TR/WCAG20-TECHS/PDF12.html
http://www.w3.org/TR/WCAG20-TECHS/PDF17.html
http://www.w3.org/TR/WCAG20-TECHS/PDF20.html
http://www.w3.org/TR/WCAG20-TECHS/PDF21.html
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WCAG 2.0  	 ISO 14289 -1 (File)  	 Techniques
1.3.2 Meaningful Sequence. 
(Level A)

•	 7.2 paragraph two 
addresses the meaningful 
sequence of content.

•	 7.17 addresses navigation 
features.

•	 7.18.3 addresses tab order 
in annotations.

•	 PDF3

1.3.3 Sensory Characteristics. 
(Level A)

•	 7.1, paragraphs 6 and 7 •	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
content-structure-
separation-understanding

1.4.1 Use of Color. (Level A) •	 7.1, paragraph 6 •	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
visual-audio-contrast-
without-color

1.4.2 Audio Control. (Level A) •	 Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
visual-audio-contrast-dis-
audio

1.4.3 Contrast (Minimum). 
(Level AA)

•	 7.1, paragraph 6 and note 4 •	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
visual-audio-contrast-
contrast

1.4.4 Resize text. (Level AA) •	 Not applicable •	 G142

1.4.5 Images of Text. (Level 
AA)

•	 7.3, paragraph 6 •	 PDF7

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
visual-audio-contrast-text-
presentation

1.4.6 Contrast (Enhanced). 
(Level AAA)

•	 7.1, paragraph 6

1.4.7 Low or No Background 
Audio. (Level AAA)

•	 While ISO 14289 does 
not address this success 
criterion, conformance in 
PDF requires ISO 14289 
conforming files and 
readers. The manner in 
which developers support 
this success criterion in 
PDF in not defined in ISO 
14289 or ISO 32000.

1.4.8 Visual Presentation. 
(Level AAA)

•	 Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

http://www.w3.org/TR/WCAG20-TECHS/PDF3.html
http://www.w3.org/WAI/WCAG20/quickref/#qr-content-structure-separation-understanding
http://www.w3.org/WAI/WCAG20/quickref/#qr-content-structure-separation-understanding
http://www.w3.org/WAI/WCAG20/quickref/#qr-content-structure-separation-understanding
http://www.w3.org/WAI/WCAG20/quickref/#qr-content-structure-separation-understanding
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-without-color
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-without-color
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-without-color
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-without-color
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-dis-audio
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-dis-audio
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-dis-audio
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-dis-audio
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-contrast
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-contrast
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-contrast
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-contrast
http://www.w3.org/TR/2012/NOTE-WCAG20-TECHS-20120103/G142
http://www.w3.org/TR/WCAG20-TECHS/PDF7.html
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-text-presentation
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-text-presentation
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-text-presentation
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-text-presentation


21Adobe Acrobat XI Accessibility Using the PDF Accessibility Checker

WCAG 2.0  	 ISO 14289 -1 (File)  	 Techniques
1.4.9 Images of Text (No 
Exception). (Level AAA)

•	 7.3 paragraph 1

2.1.1 Keyboard. (Level A) •	 Not applicable •	 PDF3

•	 PDF11

•	 PDF23

2.1.2 No Keyboard Trap. 
(Level A)

•	 Design-specific. It’s 
necessary that developers 
consider this provision and 
ensure conformance.

•	 G21

2.1.3 Keyboard (No 
Exception). (Level AAA)

•	 7.19, paragraph 3

2.2.1 Timing Adjustable. 
(Level A)

•	 7.19, paragraph three 
applies, but generally this 
rule is design-specific. It’s 
necessary that developers 
consider this provision and 
ensure conformance.

•	 G133

2.2.2 Pause, Stop, Hide. (Level 
A)

•	 7.19 •	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
time-limits-pause

2.2.3 No Timing. (Level AAA) •	 7.19

2.2.4 Interruptions. (Level 
AAA)

•	 7.19

2.2.5 Re- authenticating. 
(Level AAA)

•	 Not applicable

2.3.1 Three Flashes or Below 
Threshold. (Level A)

•	 7.1, paragraph 5 •	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
seizure-does-not-violate

2.3.2 Three Flashes.(Level 
AAA)

•	 7.1, paragraph 5

2.4.1 Bypass Blocks. (Level A) •	 Not applicable, unless the 
PDF includes repetitive 
real content. Page content, 
such as running headers 
and footers, must conform 
with 7.8.

•	 PDF9

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
navigation-mechanisms-
skip

2.4.2 Page Titled. (Level A) •	 7.1, paragraphs 8 and 9 •	 PDF18

2.4.3 Focus Order. (Level A) •	 7.1, paragraph 2, 7.18.1; 
paragraph 2, 7.18.3

•	 PDF3

2.4.4 Link Purpose (In 
Context). (Level A)

•	 7.18.5 •	 PDF11

•	 PDF13

http://www.w3.org/TR/WCAG20-TECHS/PDF3.html
http://www.w3.org/TR/WCAG20-TECHS/PDF11.html
http://www.w3.org/TR/WCAG20-TECHS/PDF23.html
http://www.w3.org/TR/2012/NOTE-WCAG20-TECHS-20120103/G21
http://www.w3.org/TR/WCAG20-TECHS/G133.html
http://www.w3.org/WAI/WCAG20/quickref/#qr-seizure-does-not-violate
http://www.w3.org/WAI/WCAG20/quickref/#qr-seizure-does-not-violate
http://www.w3.org/WAI/WCAG20/quickref/#qr-seizure-does-not-violate
http://www.w3.org/TR/WCAG20-TECHS/PDF9.html
http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-skip
http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-skip
http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-skip
http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-skip
http://www.w3.org/TR/WCAG20-TECHS/PDF18.html
http://www.w3.org/TR/WCAG20-TECHS/PDF3.html
http://www.w3.org/TR/WCAG20-TECHS/PDF11.html
http://www.w3.org/TR/WCAG20-TECHS/PDF13.html
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WCAG 2.0  	 ISO 14289 -1 (File)  	 Techniques
2.4.5 Multiple Ways. (Level 
AA)

•	 PDFs can conform with this 
provision in several ways, 
including outlines (7.17), 
links (7.18.5), and page 
labels.

•	 PDF2

•	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
navigation-mechanisms-
mult-loc

2.4.6 Headings and Labels. 
(Level AA)

•	 7.4 •	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
navigation-mechanisms-
descriptive

2.4.7 Focus Visible. (Level AA) •	 Not applicable •	 G149

•	 G165

•	 G195

2.4.8 Location. (Level AAA) •	 7.4, 7.17

2.4.9 Link Purpose (Link 
Only). (Level AAA)

•	 7.18.5

2.4.10 Section Headings. 
(Level AAA)

•	 7.4

3.1.1 Language of Page. (Level 
A)

•	 7.2, paragraph 3. •	 PDF16

•	 PDF19

3.1.2 Language of Parts. 
(Level AA)

•	 7.2, paragraph 3. •	 PDF19

3.1.3 Unusual Words. (Level 
AAA)

•	 Not addressed in ISO 
14289. See ISO 32000-1, 
section 14.9.5.

3.1.4 Abbreviations. (Level 
AAA)

•	 Not addressed in ISO 
14289. See ISO 32000-1, 
section 14.9.5.

3.1.5 Reading Level. (Level 
AAA)

•	 No Accessibility Support 
impact. This rule is design-
specific. It’s necessary that 
application or document 
authors consider this 
provision and ensure 
conformance.

3.1.6 Pronunciation. (Level 
AAA)

•	 PDF provides several 
mechanisms for deploying 
media and other options 
for pronunciation 
assistance. Design-specific. 
It’s necessary that authors 
and developers consider 
this provision and ensure 
conformance.

http://www.w3.org/TR/WCAG20-TECHS/PDF2.html
http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-mult-loc
http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-mult-loc
http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-mult-loc
http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-mult-loc
http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-descriptive
http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-descriptive
http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-descriptive
http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-descriptive
http://www.w3.org/TR/2012/NOTE-WCAG20-TECHS-20120103/G149
http://www.w3.org/TR/2012/NOTE-WCAG20-TECHS-20120103/G165
http://www.w3.org/TR/2012/NOTE-WCAG20-TECHS-20120103/G195
http://www.w3.org/TR/WCAG20-TECHS/PDF16.html
http://www.w3.org/TR/WCAG20-TECHS/PDF19.html
http://www.w3.org/TR/WCAG20-TECHS/PDF19.html
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WCAG 2.0  	 ISO 14289 -1 (File)  	 Techniques
3.2.1 On Focus. (Level A) •	 7.18, paragraph 2 •	 General Techniques: 

http://www.w3.org/WAI/
WCAG20/quickref/#qr-
consistent-behavior-
receive-focus

3.2.2 On Input. (Level A) •	 7.18, paragraph 2 •	 PDF15

3.2.3 Consistent Navigation. 
(Level AA)

•	 7.1, paragraph 1, 7.17 •	 PDF14

•	 PDF17

•	 G61

3.2.4 Consistent Identification. 
(Level AA)

•	 7.1, paragraph 1 •	 General Techniques: 
http://www.w3.org/WAI/
WCAG20/quickref/#qr-
consistent-behavior-
consistent-functionality

3.2.5 Change on Request. 
(Level AAA)

•	 7.19, paragraph 2

3.3.1 Error Identification. 
(Level A)

•	 Design-specific. It’s 
necessary that authors 
and developers consider 
this provision and ensure 
conformance.

•	 PDF5

•	 PDF22

3.3.2 Labels or Instructions 
(Level A)

6.2 •	 PDF5

•	 PDF10

4.1.2 Name, role, value 7.18 •	 PDF10

•	 PDF12

http://www.w3.org/WAI/WCAG20/quickref/#qr-consistent-behavior-receive-focus
http://www.w3.org/WAI/WCAG20/quickref/#qr-consistent-behavior-receive-focus
http://www.w3.org/WAI/WCAG20/quickref/#qr-consistent-behavior-receive-focus
http://www.w3.org/WAI/WCAG20/quickref/#qr-consistent-behavior-receive-focus
http://www.w3.org/TR/WCAG20-TECHS/PDF15.html
http://www.w3.org/TR/WCAG20-TECHS/PDF14.html
http://www.w3.org/TR/WCAG20-TECHS/PDF17.html
http://www.w3.org/TR/2012/NOTE-WCAG20-TECHS-20120103/G61
http://www.w3.org/WAI/WCAG20/quickref/#qr-consistent-behavior-consistent-functionality
http://www.w3.org/WAI/WCAG20/quickref/#qr-consistent-behavior-consistent-functionality
http://www.w3.org/WAI/WCAG20/quickref/#qr-consistent-behavior-consistent-functionality
http://www.w3.org/WAI/WCAG20/quickref/#qr-consistent-behavior-consistent-functionality
http://www.w3.org/TR/WCAG20-TECHS/PDF5.html
http://www.w3.org/TR/WCAG20-TECHS/PDF22.html
http://www.w3.org/TR/WCAG20-TECHS/PDF5.html
http://www.w3.org/TR/WCAG20-TECHS/PDF10.html
http://www.w3.org/TR/WCAG20-TECHS/PDF10.html
http://www.w3.org/TR/WCAG20-TECHS/PDF12.html
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For more information
Solution details: www.adobe.com/accessibility/products/acrobat/
Program details: www.adobe.com/accessibility
Contact information: access@adobe.com
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